przystajnik

Jeszcze lepszy digiKam 4.12

Ekipa odpowiedzialna za edytor i menadżer zdjęć digiKam stara się utrzymać zdrowe tempo comiesięcznych wydań. Choć od dłuższego czasu w programie nie zadebiutowało nic przełomowego i od paru wersji otrzymujemy tylko zestawy naprawcze, to i tak skala usprawnień budzi szacunek. I tak oto obecny digiKam 4.12 likwiduje, bagatela, 148 błędów.

Digikam3_logoNie sposób w tym miejscu przytoczyć ich wszystkich, stąd też zainteresowani mogą przejrzeć w tym miejscu listę usuniętych usterek. Dużo uwagi poświęcono ponownie jakości paczek dla OS X. Choć to wydanie zasługuje w pełni na miano naprawczego i nie uświadczymy żadnych nowych funkcji, to i tak użytkownicy digiKam powinni zaktualizować swoje programy, by uniknąć w przyszłości ew. błędów.

Program w wersji dla Ubuntu 14.04/15.04, Minta 17.X i pochodnych można zainstalować po dodaniu odpowiedniego PPA:

sudo add-apt-repository ppa:philip5/extra
sudo apt-get update
sudo apt-get install digikam

Natomiast użytkownicy Arch Linuksa i Manjaro znajdą za jakiś czas program w głównym repozytorium:

sudo pacman -S digikam

A teraz garść prywaty. Próbując jakiś czas temu i obecnie pracować na digiKamie, uświadomiłem sobie, dlaczego ten program zawsze uważałem za „inny”. Interfejs interfejsem, to kwestia przyzwyczajenia, ale głównym czynnikiem wprowadzającym zamęt jest używanie nowe nomenklatury terminów fotograficznych. Czyli „Równowaga bieli” zamiast „Balans bieli”, „Korekta naświetlania” zamiast „Ekspozycja” – co więcej, powyższe terminy są używane na przemian na różnych etapach obróbki (wywoływanie RAW – „Balans bieli”, ale już praca z obrazem – „Równowaga bieli”). Może są to głupoty i można się do nich przyzwyczaić, niemniej od lidera można wymagać precyzyjniejszego operowania przyjętą terminologią.
 

Post navigation

5 comments for “Jeszcze lepszy digiKam 4.12

  1. rob
    8 sierpnia, 2015 at 13:26

    Tak… obecny digiKam 4.12 likwiduje, bagatela, 148 błędów.
    No ale za to wprowadza jeden, tylko że mocno nieprzyjemny błąd 🙁

    „Następujące pakiety mają niespełnione zależności:
    digikam : Wymaga: libkgeomap2 (>= 1.0~digikam4.12.0) ale nie zostanie zainstalowany”

    No i dupa 🙁

  2. 8 sierpnia, 2015 at 13:38

    Widocznie paczka jest w konflikcie z jakimś innym pakietem, który masz w systemie. Wpisz w terminalu

    sudo apt-get install libkgeomap2

    … i zobaczysz, co i czemu się nie może zainstalować.

    U mnie tego problemu nie było – przypuszczam, że to efekt jakiegoś ręcznego instalowania na siłę jakichś paczek/programów.

  3. rob
    10 sierpnia, 2015 at 11:04

    Tyle to ja wiem. Efekt: „E: Nie udało się odnaleźć pakietu libkageomap2” :/
    A korzystam własnie z tego repozytorium. Z poprzednim digikamem zadnych problemów nie było

  4. rob
    10 sierpnia, 2015 at 11:13

    Literówka. Oczywiście miało być libkgeomap2

    Ale już jest OK, Rozwiązanie było tutaj http://ubuntuhandbook.org/index.php/2014/08/digikam-4-2-0-released-install-in-ubuntu-14-04/

  5. Mangure Mangure
    12 sierpnia, 2015 at 9:07

    no i nici z instalacji… co jest nie tak?świeży jestem w linuchu mincie, wyskakuje taka informacja UWAGA: Następujące pakiety nie mogą zostać zweryfikowane!
    libkface-data libkface2 libastro1 libmarblewidget19 libkgeomap-data
    libkgeomap1 digikam-data digikam
    Zainstalować te pakiety bez weryfikacji? [t/N]
    N: Ignorowanie pliku „getdeb.list.bck” w katalogu „/etc/apt/sources.list.d/”, ponieważ ma on nieprawidłowe rozszerzenie pliku
    N: Ignorowanie pliku „getdeb.list.bck” w katalogu „/etc/apt/sources.list.d/”, ponieważ ma on nieprawidłowe rozszerzenie pliku
    E: Niektóre pakiety nie mogły zostać zweryfikowane

    pomocy

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Translate »