przystajnik

NVIDIA 343.22

Nowe stabilne sterowniki NVIDII 343.22 dla Linuksa to nowe nadzieje i nowe rozczarowania. Nadzieje, bo wnoszą one wiele zmian, poprawek, obsługę nowego sprzętu (GeForce GTX 970 i GeForce GTX 980) i ogólny wzrost wydajności. To rzeczy nie do pogardzenia w czasach, gdy dla Linuksa pojawia się coraz większa liczba zaawansowanych technicznie gier, jak też nasze pulpity bez zażenowania wymagają solidnego wsparcia 3D ze strony sterowników. Rozczarowaniem można nazwać krok, który jest wynikiem postępu – w tej serii sterowników zakończono i usunięto wsparcie dla kart z serii G8x, G9x i GT2xx.

Pełna lista zmian wygląda następująco:

  • Dodano obsługę następujących układów GPU:
    • GeForce GTX 970
      GeForce GTX 980
  • Usunięto błąd, który uniemożliwiał aplikacjom EGL uznanie ustawienia „sync to vblank”.
  • Usunięto błąd, który w przypadku niektórych programów OpenGL podczas zmiany trybów mógł powodować problem braku dostępnej pamięci.
  • Usunięto błąd, który uniemożliwiał sterownikowi NVIDIA OpenGL uznawanie zmiennej środowiskowej __GL_SHADER_DISK_CACHE_PATH.
  • Usunięto błąd powodujący, że wyłączone wyświetlacze były bezwarunkowo uwzględniane jako wyświetlacze docelowe przy niektórych zapytaniach i żądaniach interfejsu linii poleceń narzędzia nvidia-settings, w przypadku gdy brak jest wyraźnie określonego obiektu docelowego.
  • Do interfejsu API narzędzia NV-CONTROL dodano nowy atrybut, który odpowiada za zapytanie o bieżące użycie silnika dekodującego wideo.
  • Usunięto błąd powodujący, że opcja Exchange Stereo Eyes narzędzia nvidia-settings nie działała poprawnie w niektórych konfiguracjach stereo.
  • Wprowadzono obejście błędu shadera Unigine Heaven 3.0, który mógł powodować przekłamania przy włączonej teselacji poprzez zaimplementowanie profilu aplikacji, która wykorzystuje ustawienie „GLIgnoreGLSLExtReqs”. W celu uzyskania szczegółowych informacji prosimy o zapoznanie się z dokumentacją zmiennej środowiskowej __GL_IGNORE_GLSL_EXT_REQS.
  • Naprawiono błąd tzw. wycieku pamięci, występujący w trakcie zniszczenia powierzchni EGL.
  • Dodano opcję jednoczesnej obsługi wielu wyświetlaczy EGL.
  • Usunięto wsparcie dla układów GPU serii G8x, G9x i GT2xx oraz opartych na nich chipsetów płyt głównych. Wsparcie dla nowych jąder systemu Linux oraz serwerów X, jak również poprawki krytycznych błędów, będą zapewniane do końca 2019 roku w wydaniach sterownika 340.* w wersji „legacy”.
  • Usunięto błąd, który mógł powodować, że w przypadku pakietów przygotowanych z opcją –add-this-kernel narzędzie nvidia-installer bez powodzenia próbowało usunąć katalog zawierający prekompilowane interfejsy modułu jądra.
  • Zaktualizowano narzędzie nvidia-installer w celu logowania procesu deinstalacji w oddzielnym pliku niż log instalacji oraz, gdy jest to możliwe, próbowało odinstalować poprzednie instalacje sterownika przy użyciu programu instalatora poprzedniej wersji.

Sterowniki 343.22 dla naszych systemów pojawią się zapewne niedługo w masowej dystrybucji za pomocą repozytorium ppa:xorg-edgers/ppa (Ubuntu/Mint i pochodne), oraz w AUR (Manjaro/Arch Linux). Należy jednak pamiętać, że jeżeli nie czujemy się na siłach, jak też nie widzimy potrzeby wymiany sterowników w naszej obecnej dystrybucji – nie należy kombinować dopóki sterowniki nie trafią do głównych repozytoriów. Wyjątkowo wymagającym użytkownikom pozostaje samodzielna instalacja za pomocą instalatora NVIDII.
 

Post navigation

Translate »