przystajnik

Shotwell 0.27 stabilny niestabilnie

Wszyscy, którzy trzymają kciuki za teoretycznie oficjalny menedżer zdjęć dla środowiska GNOME, ucieszą się na wieść o kolejnej niestabilnej wersji Shotwell 0.27. Niestabilna wersja i powód do radości? Dlaczego by nie, skoro program nawet w takiej formie zachowuje się stabilniej od wielu innych projektów. Na dodatek zawiera zmian co nie miara.

Shotwell 0.27

Jeżeli ktoś śledzi rozwój tego edytora to zapewne jest już zaznajomiony ze specyfiką parzystych wydań stabilnych (0.26.2 z 1 czerwca bieżącego roku) i niestabilnych (tytułowe 0.27). Po co jednak zawracać sobie głowę wydaniami niestabilnymi? Powodów jest kilka a co najmniej dwa. To właśnie to wydanie stanowi podwaliny pod przyszłą wersję stabilną. A po drugie, zmian jest sporo i niektóre z nich otwieraj nowy rozdział w historii projektu. Jedna z nich to zerwanie z przeszłością i pozbycie się importu zgodnego z F-Spoty, którego Shotwell zmienił na warcie jakieś 6 lat temu.

    Lista zmian

  • usunięcie wsparcia importu F-Spot,
  • przyśpieszenie operacji na kolorach,
  • narzędzie tekstowe do testowania przekształceń,
  • kosmetyka kodu rysującego histogram,
  • tworzenie miniatur uruchamiane z nice 19,
  • zaktualizowana czarna lista VAAPI dla tworzenia miniatur video i nowa struktura wtyczki,
  • konfigurowalne tło,
  • rozdzielenie niektórych okien dialogowych,
  • wtyczka odpowiedzalna za Tumblr w domyślnym zestawie,
  • wsparcie budowania binarek z wykorzystaniem Meson,
  • opcja –fullscreen/-f,
  • poprawiony schemat GSettings,
  • obejście dla błędu „Camera locked: -53” w GNOME,
  • wymagania podniesione do GTK+ 3.18 i usunięcie przestarzałych funkcji.

Wygląda to obiecująco. Wygląda również na to, że po latach żółwiego rozwoju projekt nabrał wiatru w żagle i ma szanse stać się bardzo sprawnym i poręcznym narzędziem. Jeżeli komuś leży oczywiście na sercu kwestia zarządzania kolekcją zdjęć. Co więcej, pomimo etykietki „produkt niestabilny” Shotwell 0.27 działa wręcz bez zająknięcia.

Aby przetestować program w tej wersji, musimy dodać stosowne repozytorium (dla Ubuntu 16.04/16.10/17.04, Mint 18.xx i pochodnych):

sudo add-apt-repository ppa:yg-jensge/shotwell-unstable
sudo apt-get update
sudo apt-get install shotwell

W przypadku Arch Linuksa i Manjaro wersja 0.27 powinna się pojawić w głównym repozytorium już niedługo:

sudo pacman -Suy shotwell 

Post navigation

Translate »