przystajnik

Canon ze sterownikami z PPA

UbuntuCanon od dawien dawna nie rozpieszczał użytkowników Linuksa. Niemniej nie można nie odnotować faktu, że od dłuższego już czasu na oficjalnych stronach wsparcia sprzętu ze znaczkiem Canon, można pobrać sterowniki dla Linuksa. Głównie dotyczy to wszelakich modeli drukarek i urządzeń wielofunkcyjnych, choć niestety nie wszystkich. Teraz instalacja sterowników może być jeszcze prostsza, ponieważ cały ich komplet został zebrany i umieszczony w jednym repozytorium PPA.

Repozytorium jest przeznaczone dla wydań Ubuntu 12.04/12.10/13.04 oraz Mint 13/14/15 i pochodnych. Aby z niego skorzystać, należy dodać PPA do systemu:

sudo add-apt-repository ppa:michael-gruz/canon-stable
sudo apt-get update

Teraz pozostaje zainstalować sterownik – w miejsce xxx wstawiamy model naszego urządzenia (np. ip5200):

sudo apt-get install cnijfilter-xxxseries

Pozostaje poinstruować system, aby skorzystał z świeżo zainstalowanej wersji oprogramowania. Dlatego w ustawieniach systemowych należy usunąć poprzednio zainstalowaną drukarkę i dodać ją ponownie, wybierając tym razem nowy sterownik.

Aby upewnić się, czy nasze urządzenie możemy wesprzeć sterownikiem z tego PPA, należy upewnić się, że występuje ono na tej liście

Post navigation

3 comments for “Canon ze sterownikami z PPA

  1. Wojciech
    24 maja, 2013 at 8:26

    Miło, że Canon wreszcie zauważa Linuksa – pewnie gdzieś tam na górze korporacji odnotowano, że linuksowcy kupują produkty konkurencji. Niestety lista oficjalnie wspieranych urządzeń nie jest zbyt długa. Przede wszystkim brakuje popularnych urządzeń Image Runner (IRxxxx). Ciekawostką może być fakt, że np. do ir2520 Canon teoretycznie daje sterowniki, ale niedziałające. Żeby uruchomić drukarkę, trzeba poszukać sterowników w Internecie, o skanerze można zapomnieć.

  2. Dracon
    2 stycznia, 2014 at 21:08

    Fajne było, ale nie jest – dostaję komunikat, że:
    „Nie udało się pobrać http://ppa.launchpad.net/michael-gruz/canon-stable/ubuntu/dists/saucy/main/source/Sources 404 Not Found”

    Wygląda na to, że gość nie popełnił w ogóle sterów do SAUCY (13.10), które teraz używam w postaci MINT 16 KDE. 🙁
    SalvaDhorze – czy jest jakiś ratunek??? 😮

  3. 2 stycznia, 2014 at 21:42

    Zatem, trzeba wykorzystać sterowniki dla Raring’a 🙂

    sudo -s

    echo „deb http://ppa.launchpad.net/michael-gruz/canon-stable/ubuntu raring main” > /etc/apt/sources.list.d/canon-stable.list

    echo „deb-src http://ppa.launchpad.net/michael-gruz/canon-stable/ubuntu raring main” > /etc/apt/sources.list.d/canon-stable.list

    apt-key adv –keyserver keyserver.ubuntu.com –recv-keys 3F7B4A1D

    apt-get update

    exit

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Translate »