przystajnik

Nvidia 310.14, bo warto

Choć 310.14 to wydanie beta, to warto rozważyć instalację tych sterowników NVIDII, lub co najmniej trzymać rękę na pulsie. Zawierają one bowiem ociekające świeżym kodem nowości i poprawiają wiele mankamentów wyświetlania obrazu, jak choćby niesławne błahostki w postaci niebieskich twarzy na YT, czy znikającego launchera w Unity. Lecz pełen Changelog dla tej wersji zawiera również mnóstwo innych ciekawostek, jak choćby obsługa OpenGL 4.3, czy poprawki dla RandR.

Pełna lista zmian jest wymowna – ma być szybciej, precyzyjniej i z rozmachem:

  • Dodano obejście dwóch błędów programu Adobe Flash poprzez dodanie zmiany ca9e637c61e80145f0625a590c91429db67d0a40 biblioteki libvdpau do wersji biblioteki libvdpau dostarczanej ze sterownikiem NVIDIA.
  • Naprawiono błąd wpływający na wydajność przesuwanych okien aplikacji VDPAU uruchamianych w niektórych menedżerach kompozycji.
  • Dodano nieoficjalną obsługę protokołu GLX (np. dla pośredniego renderowania GLX) dla rozszerzenia OpenGL – GL_ARB_pixel_buffer_object.
  • Dodano obsługę HDMI 3D Stereo dla układów GPU Quadro Kepler i nowszych. W celu uzyskania szczegółowych informacji prosimy zapoznać się z dokumentacją opcji konfiguracji „Stereo” serwera X w pliku README.
  • Dodano próbne wsparcie dla optymalizacji wątkowych OpenGL, dostępne poprzez zmienną środowiskową __GL_THREADED_OPTIMIZATIONS. W celu uzyskania dodatkowych informacji prosimy zapoznać się z sekcją „Threaded Optimizations” rozdziału „Specifying OpenGL Environment Variable Settings” pliku README.
  • Usprawniono wydajność i czas reakcji okienkowych aplikacji OpenGL działających wewnątrz sesji wtyczki Unity.
  • Dodano obsługę OpenGL 4.3.
  • Dodano obsługę właściwości danych wyjściowych „Backlight” rozszerzenia RandR do konfiguracji jasności matrycy w niektórych notebookach.
  • Usunięto błąd uniemożliwiający pokazanie panelu uruchamiania Ubuntu Unity po jego wcześniejszym ukryciu: https://bugs.launchpad.net/unity/+bug/1057000.
  • Naprawiono błąd powodujący, że program nvidia-installer czasami próbował zapisać plik dziennika w nieistniejącym katalogu.
  • Naprawiono błąd powodujący niepoprawną transformację danych wejściowych po zmianie wielkości ekranu NVIDIA X z serwerem X ABI 12 (xorg-server 1.12) i nowszymi.
  • Naprawiono błąd powodujący, że rozszerzenie GLX powodowało tzw. wyciek pamięci podczas włączonego rozszerzenia Xinerama.

To wydanie jest znamienne również w innym względzie, gdyż wraz z rozpoczęciem etapu rozwoju 310.xx, w niepamięć odeszła obsługa kart graficznych serii GForce 6. Dla tych kart należy używać sterowników co najwyżej 304.XX.

A pytanie zasadnicze brzmi – ‚jak skorzystać z tych sterowników w Ubuntu 12.04/12.10 lub Mint 12/13?’. Odpowiedź jest zaskakująca, wystarczy bowiem dodać odpowiednie repozytorium PPA i wykonać aktualizację (która jest zasadna, o ile korzystaliśmy z zamkniętych sterowników), lub po prostu zainstalować najnowszą wersję sterowników:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings
 

Post navigation

  • tp

    ok a co z posiadaczami optimus i bumblebee ?

  • Pidipius

    Na razie chyba musimy czekać…

Translate »