przystajnik

GIMP – rejterada z wersji 2.7.5 do 2.7.4

Lata i wieki całe obiecanek, planów, nieoczekiwanych wydań i opóźnień, tajemniczych zniknięć deweloperów i innych przygód. Udało się jednak doprowadzić sprawy do końcowego odliczania i wszyscy z nerwowym bębnieniem palców o blat biurka czekamy, aż GIMP 2.8 zaszczyci nas swoją obecnością.Jednak na drodze do ziemi obiecanej 2.8 znajdują się kolejne niestabilne i testowe wydania 2.7.x. Dla ich pozyskania większość użytkowników Ubuntu i Minta korzysta z repozytorium ppa:matthaeus123/mrw-gimp-svn, jednak awaryjność znajdujących się tam pakietów i ich kolejnych wydań może doprowadzić do stanów szewskich. Podobnie było z ostatnią aktualizacją do wersji 2.7.5, która pomimo kompilacji w wersji dla Ubuntu 11.10 (Oneiric), bez skrupułów zażądała zależności z przyszłej wersji Ubuntu 12.04 (Precise).

The following packages have unmet dependencies:gimp : Depends: libglib2.0-0 (>= 2.31.2) but 2.30.0-0ubuntu4 is to be installedE: Unable to correct problems, you have held broken packages.

Problem można rozwiązać dwojako. Dodać repozytoria zawierające odpowiednie wersje bibliotek GLIB i GTK i zaktualizować system – lecz w ten sposób otrzymamy mieszankę wydań 11.10 i 12.04 i sam Canonical chyba nie wie, do czego to może doprowadzić*.

Jednak ja zajmę się powrotem do wersji 2.7.4. Odbędzie się to za pomocą usunięcia z systemu feralnych pakietów GIMPa, usunięcie brużdżącego nam repozytorium i dodaniu innego, z działającą wersją 2.7.4.

Usuńmy zatem siedlisko zła:

sudo rm /etc/apt/sources.list.d/matthaeus123-mrw-gimp-svn-oneiric*.*

Jeżeli ktoś ma zainstalowane, to może użyć do powyższego ppa-purge.

Dodajmy siedlisko dobra:

sudo add-apt-repository ppa:jmou/ppa

Pozbądźmy się starych paczek:

sudo apt-get remove --purge gimp* libgegl* libbabl*

I zainstalujmy te dobre:

sudo apt-get update
sudo apt-get install gimp

I jeżeli nie stanęły nam na drodze jakieś nieprzewidziane okoliczności, staliśmy się posiadaczami GIMPa 2.7.4. A co z 2.7.5 i ew. 2.8? Cóż, niedługo doczekamy się wersji Ubuntu LTS 12.04, przypuszczalnie dla tego wydania owe paczki powstaną już bez trudności.

GIMP 2.7.4, na razie

* Gdyby ktoś poczuł napływ odwagi podsycanej desperacją, to…

sudo add-apt-repository ppa:ricotz/unstable
sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update
sudo apt-get upgrade
 

Post navigation

  • Heyahero

    Podążałem krok za krokiem, ale przy instalacji wyrzuciło mi coś takiego:

    gimp: Depends: python-gtk2 (>= 2.8.0) ale 2.24.0-3 zostanie zainstalowany
          Depends: libc6 (>= 2.11) ale 2.15-0ubuntu5 zostanie zainstalowany
          Depends: libfontconfig1 (>= 2.8.0) ale 2.8.0-3ubuntu6 zostanie zainstalowany
          Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) ale 2.25.2-0ubuntu2 zostanie zainstalowany
          Depends: libglib2.0-0 (>= 2.30.0) ale 2.31.20-0ubuntu2 zostanie zainstalowany
          Depends: libgtk2.0-0 (>= 2.24.6) ale 2.24.10-0ubuntu5 zostanie zainstalowany
          Depends: libjpeg62 (>= 6b1) ale 6b1-2ubuntu1 zostanie zainstalowany
          Depends: libpoppler-glib6 (>= 0.16) ale nie zostanie zainstalowany
          Depends: librsvg2-2 (>= 2.14.4) ale 2.35.2-0ubuntu1 zostanie zainstalowany
          Depends: zlib1g (>= 1:1.1.4) ale 1:1.2.3.4.dfsg-3ubuntu4 zostanie zainstalowany

    Hmm, jako zielony w kwestii linuxa zapytam: „aleosochozi” (Ubuntu 12.04)?

  •  To dlatego, że podane przez mnie repozytorium zawiera wersję GIMPa dla Ubuntu 11.10, a Ty masz 12.04. Jednocześnie, usuwanie trefnego repo podałem dla przypadku posiadania 11.10 (sudo rm /etc/apt/sources.list.d/matthaeus123-mrw-gimp-svn-oneiric*.* – u Ciebie zamiast ‚oneiric’ jest ‚precise’ – wystarczy podmienić tę nazwę). Finalnie – z repo podanego przez mnie nic nie zainstalujesz, nie masz usuniętego starego repo Matthaeusa, system próbuje instalować wersję właśnie od niego – i z takim rezultatem jak widzisz. Chyba, że próbowałeś instalować GIMPa z jeszcze jakiegoś innego miejsca. Spróbuję się rozejrzeć za paczkami dla 12.04 – jak na coś wpadnę, dam Ci znać na wiadomym forum 🙂

  • heyahero (OlyClub)

    Mint 12…. i działa. Ubu mnie coś ostatnio nerwiło 😉

  • Konrad Podgórski

     dzięki za instrukcję, działa bez problemu

Translate »