przystajnik

Darktable 0.8

Faktem stała się kolejna stabilna wersja świetnego programu do graficznych manipulacji zdjęciami. Darktable w wersji 0.8 to nie tylko poprawki błędów, ale ogromne ilości zmian w funkcjonalności programu oraz nowe wersje filtrów i nie tylko.

– spory skok w szybkości ładowania plików RAW dzięki użyciu bibliotek RawSpeed (zapożyczenie z projektu Rawstudio),
– poprawki wydajnościowe w obsłudze pamięci podręcznej i potoków pikseli,
– wsparcie dla filtrów/pluginów ze strony GPU dzięki użyciu OpenCL (dla obsługujących tę funkcjonalność kart graficznych),
– edytor metadanych,
– HDR i mapowanie tonalne (eksperymentalnie),
– wysyłanie plików np. na Flickr,
– w porównaniu do wersji 0.7.1 więcej filtrów i pluginów.

Co można napisać o samym programie i nowej wersji. Chyba tylko sam ciepłe słowa, bo prężnie rozwijany Darktable jest uzupełniany ciekawymi poprawkami, jest stabilny, jest szybki, jakości generowanych efektów też nie można nic zarzucić. Kwestia przyzwyczajenia się do interfejsu (inny nie znaczy gorszy) i wypracowania swoich metod obróbki.

Program w wersji dla Ubuntu Lucid/Maverick można zainstalować po dodaniu repozytoriów:

sudo add-apt-repository ppa:pmjdebruijn/darktable-release

Dla eksperymentatorów i ludzi ciekawych świata dostępne jest też repozytorium ppa:pmjdebruijn/darktable-unstable w którym ze sporą regularnością pojawiają się wersje testowe programu.

W przypadku Debiana pozostaje własnoręczna kompilacja, bądź sprawdzanie od czasu do czasu np. tego źródła.
 

Post navigation

  • EuGene

    Niestety aktualizacja darktable z podanego repo chce usunąć u mnie 7 pakietów (w tym wine, flasha i teamviewera)

  • Aligaga

    Niestety… Przy próbie uruchomienia konsola wypluwa:

    [image_cache_read] failed to recover the cache from `/home/aliga/.cache/darktable/mipmaps’
    Illegal instruction

    i program kończy pracę nawet nie jej nie zaczynając. Jaka tego jest przyczyna i jak to naprawić?.. ;-/… Jakś rada?…

  • @Aligaga

    Może jest to związane z używaniem poprzedniej wersji Darktable? Może usunięcie katalogu .cache/darktable pomoże?

  • Aligaga

    @Salvadhor:
    To o czym piszesz zrobiłem w pierwszej kolejności… I nic…

  • @Aligaga

    No to gorsza sprawa, pozostają stanowcze, męskie, ale trudniejsze rozwiązania problemu. Albo zdebugować darktable poleceniem gdb i zobaczyć, co i w którym momencie mu nie pasuje, albo przypomnieć sobie język rosyjski i zerknąć na temat na grupie dyskusyjnej:

    http://www.linuxgraphics.ru/forum/viewthread.php?thread_id=943&rowstart=0

  • Aligaga

    @Salvadhor
    Wynik debugowania:

    ~$ gdb darktable
    GNU gdb (GDB) 7.2-debian
    Copyright (C) 2010 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law. Type „show copying”
    and „show warranty” for details.
    This GDB was configured as „x86_64-linux-gnu”.
    For bug reporting instructions, please see:

    Reading symbols from /usr/bin/darktable…(no debugging symbols found)…done.
    (gdb) run
    Starting program: /usr/bin/darktable
    [Thread debugging using libthread_db enabled]
    [New Thread 0x7fffe8cc7700 (LWP 31982)]
    [New Thread 0x7fffe7d62700 (LWP 31991)]
    [New Thread 0x7fffe714a700 (LWP 31992)]
    [New Thread 0x7fffe6949700 (LWP 31993)]
    [New Thread 0x7fffe6148700 (LWP 31994)]
    [New Thread 0x7fffe5947700 (LWP 31995)]
    [New Thread 0x7fffe5146700 (LWP 31996)]
    [New Thread 0x7fffe4945700 (LWP 31997)]
    [New Thread 0x7fffe4144700 (LWP 31998)]
    [New Thread 0x7fffe3943700 (LWP 31999)]
    [image_cache_read] failed to recover the cache from `/home/aliga/.cache/darktable/mipmaps’

    Program received signal SIGILL, Illegal instruction.
    0x00007fffd2949de3 in ?? () from /usr/lib/darktable/views/liblighttable.so
    (gdb)

    I tu się wywala… Wybacz ale nie jestem programistą a grafikiem… Jak Tobie coś do głowy przyjdzie to będę wdzięczny.. :-)… Nadmienię jeszcze iż poprzednia wersja działała bezproblemowo a system to debian sid 64 bit …

  • Paool

    hmm, a u mnie się zaktualizował, działa i niczego usuwać nie chiał 😛

  • Przemas

    U mnie też działa Ubuntu 10.04 LTS@32bit

  • Ja również nie spotkałem się z żadnymi problemami przy instalacji aktualizacji i późniejszym korzystaniu z tego programu.

Translate »