przystajnik

OpenOffice vs Compiz

Słabo piśmienny jestem, to i edytor tekstu rzadko uruchamiam. Ale od małżonki otrzymałem domowe polecenie służbowe zrobić ‚coś’ z denerwującym efektem rwania się fontów podczas pisania w Open Office’ie. Co to jest ‚rwanie fontów’? A to:

Problem pojawiał się podczas wprowadzania tekstu, przejścia z linii do linii, przesuwania tekstu, itp. W zasadzie uniemożliwiał sensowną pracę, bo ciągłe naciskanie ctrl+shift+R to niewiele ma wspólnego z wygodą.

Na początku podejrzewałem najnowszą wersję OpenOffica 3.1.1. Ale ponieważ nie znalazłem w sieci potwierdzenia tego błędu, swoją nieufność przeniosłem na włączonego Compiza. Po wyłączeniu efektów pulpitu wszystko się uspokoiło. No i mamy winowajcę. Ale przecież nie wyłączę całkiem Compiza – żeby się koledzy z Windows 7 ze mnie naśmiewali?

Zatem – albo sterowniki Nvidii, albo jakoś specyficzna opcja w Compizie. Sterowniki posiadam najnowsze (195.30), dlatego zajrzałem w inne miejsce. I udało się.

Przepis jest następujący – jeżeli ktoś nie posiada, należy zainstalować compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Udajemy się do ustawień System->Preferencje->Menedżer Ustawień CompizConfig. Po uruchomieniu konfiguratora kolejny krok to wybranie opcji Narzędzia->Obejścia problemów->Force synchronization between X and GLX. Gotowe.

Przypuszczam, że problemy występuje tylko przy użyciu zamkniętych sterowników Nvidii – sprawdzenia na sprzęcie i sterownikach ATI tudzież Intela możliwości nie mam.
 

Post navigation

  • Na moim intelu problem nie występuje 😉

  • Złoty

    Na moim radeonie 3200 nie występuje

  • U mnie (OO 2.4, ale również wcześniejsze), na XPH-SP3, Intel 945, też to występuje, choć nie jest jakoś bardzo uciążliwe.

  • herq

    A na moim:
    Intel(R) 965GME/GLE GEM 20090712 2009Q2 RC3 x86/MMX/SSE2
    Version : 2.1 Mesa 7.6
    występuje 🙂

  • ms-trex

    A u mnie wystepuje to nawet na windowsie, wkurza mnie to już jak nie wiem.

Translate »